1. این پایگاه به ثبت ستاد ساماندهی وزارت فرهنگ و ارشاد اسلامی ایران رسیده است.

    مهمان عزیز سپاس بابت بازدید شما از تالار گفتگوی دهه هفتادی ها.

    عضویت در انجمن رایگان بوده و برای عموم باز میباشد . با صرف 30 ثانیه یکی از اعضای دهه هفتادی ها شوید .

مرورگر شما در خطر حمله امنیتی Poodle است

شروع موضوع توسط Admin ‏Oct 27, 2014 در انجمن هک و امنیت

  1. Admin

    Admin غواصی فقط تو چشات عضو کادر مدیریت مدیر کل سایت

    12,498
    24,596
    62,574
    POODLE نوعی سگ پشمالو و باهوش است، ولی هنگامی که سخن از اینترنت و مرورگر به میان می‌آید، این POODLE ‌آسیب‌پذیری جدی است که به تازگی کشف شده و شاید هم‌اکنون مرورگر شما را نیز تحت تأثیر گذاشته باشد؛ اما POODLE و راه‌های مقابله با آن چیست؟
    به گزارش «تابناک»، POODLE مخفف عبارت Padding Oracle Downgraded Legacy Encryption است که در واقع یک خطر امنیتی بزرگ تلقی می‌شود که تا کنون بسیاری را آلوده کرده است. همچنین به عنوان یک آسیب‌پذیری امنیتی می‌تواند همه مرورگر‌ها را آلوده کرده و به آن‌ها حمله کند؛ اما برای مقابله با آن نخست لازم است، نحوه کار POODLE را تشریح کنیم.

    [​IMG]
    اطلاعات اساسی

    برای درک آسیب‌پذیری POODLE نخست باید چیزهایی از‌ SSL و TLS بدانیم. این دو پروتکل رمزنگاری شده هستند تا از ارتباطات اینترنتی مهم شما نگهداری کنند. وقتی به یک وب‌سایت می‌روید و در ابتدای آدرس آن عبارت HTTPS: // را می‌بینید، در حال استفاده از پروتکل SSL/TLS هستید. پروتکل SSL یا Secure Socket Layer و TLS یا Transport Security Layer ‌با هم تفاوت‌هایی دارند، ولی بیشتر آن‌ها را یکجا با نام SSL خطاب می‌کنند.

    بنا بر این گزارش، SSL حدود ده سال توسط TLS جایگزین شد، ولی هنوز به شکل گسترده‌ای از آن استفاده می‌شود. همین نکته است که POODLE را خطرناک‌تر می‌سازد.

    وقتی از یک صفحه وب بازدید می‌کنید، رایانه‌ای که وب‌سایت را برای شما می‌آورد‌ (وب سرور) قادر به ایجاد سطوح گوناگونی از رمزگذاری از TLSv1.‌2 یعنی آخرین و امن‌ترین استاندارد تا SSLv3 یعنی قدیمی‌ترین و نا‌امن‌ترین نوع رمزگذاری است. این امر به مرورگر و وب سرور اجازه می‌دهد ‌از مسیر یک پروتکل با یکدیگر مرتبط شوند تا به شکلی امن با هم ارتباط بر‌قرار کنند. این‌‌ همان راه اساسی است که از طریق آن مرورگر‌ها و وب سرور‌ها به مقابله با حملات از نوع Man-in-the-Middle می‌پردازند؛ حملاتی که POODLE نیز جزوی از آنهاست.

    برای مشاهده لینک ها لطفا ثبت نام کنید و یا اگر حساب کاربری دارید وارد شوید



    POODLE چگونه کار می‌کند؟

    ‌‌POODLE وب سرور و مرورگر را مجبور به تنزل به پروتکل SSLv3 می‌کند. با این کار هکر قادر به دریافت اطلاعات در ارتباط بین این دو می‌شود؛ این به آن معناست که هکر می‌تواند به Cookie‌ها که برای ذخیره اطلاعات به شکل متن کاربرد دارند دسترسی پیدا کند. برخی از این Cookie‌ها حاوی اطلاعات شخصی و حساس شما هستند.

    از ‌سویی باید گفت، حمله از نوع POODLE ساده‌ترین راه برای هکر در راستای دسترسی به اطلاعات شما نیست. نخست باید بررسی کنیم، ‌آیا شما در برابر حملات POODLE آسیب‌پذیر هستید یا خیر. برای فهمیدن این موضوع به وب سایت POODLETest در

    برای مشاهده لینک ها لطفا ثبت نام کنید و یا اگر حساب کاربری دارید وارد شوید

    بروید. اگر در این صفحه سگی را با نام NOT Vulnerable ‌دیدید، مرورگر شما آسیب ناپذیر است؛ اما اگر سگی با نام Vulnerable دیدید، مرورگر شما آسیب‌پذیر است.

    [​IMG]
    کاربران حرفه ای می‌توانند برای دریافت اطلاعات اساسی‌تر به

    برای مشاهده لینک ها لطفا ثبت نام کنید و یا اگر حساب کاربری دارید وارد شوید

    مراجعه کنند.

    راه اصلی مقابله با این حمله غیر فعال کردن SSLv3 در مرورگر است. اگر این قابلیت غیر‌فعال باشد، POODLE توان اجبار مرورگر به تنزل به SSLv3 را ندارد. بگذارید تا راه غیر فعال کردن این پروتکل رمزگذاری را در گوگل کروم، فایرفاکس و IE به شما نشان دهیم.

    اما پیش از شروع ذکر این نکته ضروری است که بسیاری از وب‌سایت‌ها هنوز از SSLv3 استفاده می‌کنند و در صورت غیر فعال کردن این پروتکل ممکن است این وب‌سایت‌ها مانند سابق کار نکنند. البته این مشکل خود این وب سایت‌ها است و باید هرچه زودتر خود را به TLS ارتقا دهند.

    در مرورگر گوگل کروم

    بر روی آیکون این مرورگر در سیستم خود کلیک راست کرده و گزینه Properties را برگزینید.

    [​IMG]
    در پنجره Properties به دنبال فیلد Target بگردید. این فیلد آدرس مکانی را که کروم در آن است، نشان می‌دهد. در پایان این آدرس یعنی بعد از علامت کوتیشن (") در پایان آدرس یک فاصله گذاشته و عبارت زیر را در ادامه وارد کنید.

    ––ssl-version-min=tls1

    همچنین می‌توانید این عبارت را عینا از اینجا کپی و در این فیلد وارد کنید. این عبارت به کروم می‌گوید، آخرین نسخه پروتکل رمزگذاری که مجاز به استفاده از آن است، TLSv1 ‌بوده و مجاز به تنزل به نسخه پایین تر نیست. ‌روی Apply کلیک کنید و این پنجره را ببندید.

    [​IMG]
    در مرورگر اینترنت اکسپلورر

    مرورگر IE را باز کرده و ‌روی آیکون تنظیمات کلیک ‌و گزینه Internet Options را انتخاب کنید.

    [​IMG]
    در آخرین تب یعنی تب Advanced و در بخش Settings در بین گزینه‌ها پایین بیایید تا به گزینه‌های Use SSL 2.0 و USE SSL 3.0 برسید.

    [​IMG]
    اگر این گزینه‌ها فعال و انتخاب شده هستند، همه آنها را غیر فعال کنید. همچنین مطمئن شوید، گزینه‌های Use TLS 1, TLS 1.1, TLS 1.2 فعال باشد. اگر همه این سه گزینه را نمی بینید، باید مرورگر خود را به‌روزرسانی کنید. در نهایت همه چیز را OK کنید و صفحه را ببندید.

    در مرورگر فایرفاکس

    اگر مانند ما یکی از طرفداران پر و پا قرص فایرفاکس هستید، خبر خوش برای شما این است که کافی است افزونه SSL Version Control را به مرورگر خود بیفزایید – از

    برای مشاهده لینک ها لطفا ثبت نام کنید و یا اگر حساب کاربری دارید وارد شوید

    . به همین سادگی.

    [​IMG]
    همچنین موزیلا خبر داده ‌که نسخه بعدی فایرفاکس ‌(نسخه 34) به کلی پشتیبانی از SSLv3 را ملغی خواهد کرد. به همین دلایل ‌است که ما فایرفاکس را دوست داریم. هر چند این نسخه احتمالا تا ماه نوامبر بیرون نخواهد آمد.

    نظر شما درباره POODLE و راه‌های مقابله با آن چیست؟ آیا ابزارها و نرم‌افزارهای دیگری برای مقابله با این حمله خطرناک می‌شناسید‌؟
     
    MahDiyaR Mjd، Avin Devil، !!HISS!! و 2 نفر دیگر از این ارسال تشکر کرده اند.